[Win XP] Demo crashes when starting

This is the place to talk about BotS, ask for help, report bugs and release maps.

[Win XP] Demo crashes when starting

Postby Absalom526 » Mon Jun 03, 2013 4:15 pm

I didn't see any troubleshooting on this site, so I thought to let you know Battle of the Sands crashes as soon as the "Tutorial Campaign" starts. I'm playing the demo on a Win XP SP3 machine, if it matters. I also know other people who've had this problem.
Absalom526
Centaur (CR 3)
 
Posts: 9
Joined: Mon Jun 03, 2013 4:09 pm

[Win XP] Demo crashes when starting

Advert
 

Re: Demo crashes when starting

Postby BlueSalamander » Mon Jun 03, 2013 9:55 pm

Hello Absalom526, thank you for the bug report.

Is that version 1.008 or 1.007?

Did you install the game in the default directory?

Does the game also crash if you try a Single Map?

Is it possible for you to take a screenshot of the crash (with the print screen key)?

Has anyone else managed to get the demo running in Windows XP?

Thanks!
'Say there is a chunk of meat. Pirates will have a banquet and eat it! But heroes will share it with other people. I want all the meat!!' - Luffy in One Piece
User avatar
BlueSalamander
Master Conjuror
 
Posts: 1292
Joined: Sun May 18, 2008 6:20 pm

Re: Demo crashes when starting

Postby Absalom526 » Wed Jun 05, 2013 1:00 am

I have v 1.008, and yes I did install into the default directory.
Image The crash was a hard lock, no error message except this windows error report info after I closed it for not responding.
Same problem with a single player map, maybe one second after gameplay starts it hardlocks and has to shut down from the task manager.
Absalom526
Centaur (CR 3)
 
Posts: 9
Joined: Mon Jun 03, 2013 4:09 pm

Re: Demo crashes when starting

Postby BlueSalamander » Wed Jun 05, 2013 8:17 am

O.k. so if I understand correctly: the game simply freezes one second after gameplay starts.
So it does not seem to be a bug. I think it may be something in your system that slows the game down.

For example, on my system, if I switch to 16-bit colour depth, the game slows down greatly. Please try both 16-bit colour and 32-bit colour, does this do any good?

Also, looking into Google, there seems to be quite a few people who experience game freezes with XP:
http://www.google.com/search?hl=en&source=hp&q=game+freezes+on+windows+xp&gbv=2&oq=game+freezes+on+windows+xp&gs_l=heirloom-hp.3..0i22i30l2.10551.10551.0.10996.1.1.0.0.0.0.253.253.2-1.1.0...0.0...1ac.1.15.heirloom-hp.BOpDn6l6t7k
'Say there is a chunk of meat. Pirates will have a banquet and eat it! But heroes will share it with other people. I want all the meat!!' - Luffy in One Piece
User avatar
BlueSalamander
Master Conjuror
 
Posts: 1292
Joined: Sun May 18, 2008 6:20 pm

Re: Demo crashes when starting

Postby Absalom526 » Wed Jun 05, 2013 12:43 pm

Yeah I tried it. Screws up the text when I tried changing color depth to 16 bit as well. And all operating systems have bugs when playing games.
Absalom526
Centaur (CR 3)
 
Posts: 9
Joined: Mon Jun 03, 2013 4:09 pm

Re: Demo crashes when starting

Postby BlueSalamander » Wed Jun 05, 2013 9:06 pm

Right. What's your graphics card and RAM?

About Win XP, I didn't mean that it's any worse or better than other operating systems.
I just mentioned the link because maybe someone in there has already found the explanation and solution for freezing OpenGL games (though I can't see it, so far).

It's rather strange that the game would work well in Vista/7/8 but not XP.

PS If anyone else has got the demo running in XP, please let me know. Cheers
'Say there is a chunk of meat. Pirates will have a banquet and eat it! But heroes will share it with other people. I want all the meat!!' - Luffy in One Piece
User avatar
BlueSalamander
Master Conjuror
 
Posts: 1292
Joined: Sun May 18, 2008 6:20 pm

Re: Demo crashes when starting

Postby Absalom526 » Wed Jun 05, 2013 10:57 pm

Nvidia geforce 6200 and it has 256 mg of Ram
Absalom526
Centaur (CR 3)
 
Posts: 9
Joined: Mon Jun 03, 2013 4:09 pm

Re: Demo crashes when starting

Postby BlueSalamander » Thu Jun 06, 2013 12:40 pm

That sounds fine. What is your computer's RAM? Do any of your games run slowly or is BotS the only exception?
'Say there is a chunk of meat. Pirates will have a banquet and eat it! But heroes will share it with other people. I want all the meat!!' - Luffy in One Piece
User avatar
BlueSalamander
Master Conjuror
 
Posts: 1292
Joined: Sun May 18, 2008 6:20 pm

Re: Demo crashes when starting

Postby Absalom526 » Thu Jun 06, 2013 7:54 pm

BlueSalamander wrote:That sounds fine. What is your computer's RAM? Do any of your games run slowly or is BotS the only exception?


2 GBs of Ram. I haven't had any problems with other games recently.
Absalom526
Centaur (CR 3)
 
Posts: 9
Joined: Mon Jun 03, 2013 4:09 pm

Re: Demo crashes when starting

Postby BlueSalamander » Thu Jun 06, 2013 10:27 pm

O.k. Maybe 2 GB is a bit too low. What's the processor speed?
Unfortunately I can't do anything about this for the moment. Sorry about that.
I still don't know whether it's due to Win XP, RAM that is too low, a CPU that is too slow, certain graphic-card settings, or a problem in the game's code.
'Say there is a chunk of meat. Pirates will have a banquet and eat it! But heroes will share it with other people. I want all the meat!!' - Luffy in One Piece
User avatar
BlueSalamander
Master Conjuror
 
Posts: 1292
Joined: Sun May 18, 2008 6:20 pm

Next

Return to About the Battle of the Sands RTS

Who is online

Users browsing this forum: No registered users and 1 guest

cron